注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

姑射道人的博客

博客新地址:nixuchen.com

 
 
 

日志

 
 

Application does not specify an API level requirement”解决办法  

2014-02-12 15:12:25|  分类: android |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
 在运行Android程序时,有时候会出现以下提示

[2010-05-28 19:03:03 - rss_reader]WARNING: Application does not specify an API level requirement!
[2010-05-28 19:03:03 - rss_reader]Device API version is 12 (Android 3.1)

    其中Android 3.1表示工程使用的Androidsdk版本,示例中使用的是3.1版本;12是设备的API版本,出现该提示,是因为工程中没有配置设备API版本,只需要在文件AndroidManifest.xml中添加上相应的配置信息即可。
    示例如下:

<manifest ……>
    <application ……">
        ……
    </application>
    <uses-sdk android:minSdkVersion="12"></uses-sdk>
</manifest>

    注意,红字部分是采用的设备API版本号;users-sdk节点同application节点在同一级别。

  评论这张
 
阅读(415)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017